• +48 530 88 77 99
  • info@thecamels.org

Dlaczego warto przejść na PHP 7.1?

Michał Olber komentarzy: 0

Od zawsze namawiamy do aktualizacji oprogramowania. Bardzo często przynosi ono nowe funkcje, lepszą wydajność oraz usunięcie błędów w poprzednich wersjach. 19 stycznia 2017 roku PHP 5.6 straciło aktywne wsparcie swoich twórców. Oznacza to, że język ten nie jest już dalej aktywnie rozwijany. Obecnie twórcy wprowadzają jedynie krytyczne poprawki bezpieczeństwa. Co zatem należy zrobić już teraz, aby nasze strony działały nadal? Czy warto przenieść się na PHP 7.1?

Dlaczego warto przejść na PHP 7.1?

Najważniejszym argumentem, przemawiającym za migracją jest brak rozwoju PHP 5.6. Jak możemy zobaczyć, na wykresie rozwój zakończył się już na początku stycznia 2017 roku. A obecnie mamy początek października. Zatem przez ostatnie 9 miesięcy nie działo się nic. Twórcy tego języka dodają jedynie poprawki bezpieczeństwa. Będę wydawane aż do 31 grudnia 2018. Po tej dacie, PHP 5.6 straci całkowicie wsparcie i większość serwerów przestanie również udostępniać tę wersję.

PHP Currently Supported Versions

Opóźnianie migracji może wpłynąć niekorzystnie na szybkość działania strony, sklepu lub wtyczki. Mówimy tutaj o WordPress, Prestashop, Joomla, Drupal i innych skryptach opartych o język PHP. Deweloperzy tych CMSów już dawno dodali wsparcie dla PHP 7.1, które daje o wiele większe możliwości.

Największą zaletą PHP 7.1 jest wzrost szybkości. Wzrost wydajności wynosi od 180% do nawet 400%. Jest to zatem jeden z ważniejszych argumentów przemawiających za migracją na nową wersję PHP. Widoczne jest to w tych testach:

Drugim ważnym argumentem jest bieżący rozwój. Deweloperzy cały czas dodają nowe funkcje oraz naprawiają znalezione błędy. Poprawiana jest również wydajność w każdym nowym wydaniu.

Jak przejść na nową wersję PHP?

Proces migracji na PHP 7.1 warto dokładnie zaplanować i wykonywać go etapami. Na początek dobrze jest sprawdzić, czy nasza strona ze wszystkimi jej komponentami bez problemów ruszy na nowej wersji. W tym celu tworzymy jej roboczą kopię i wykonujemy kroki, jak w poniższych poradnikach.

WordPress

Wsparcie dla PHP 7.0 pojawiło się już w WordPress 3.6, czyli w IV kwartale 2015 roku. Deweloperzy zaczęli również zaktualizować wtyczki. Najnowsze wersje WordPressa, od 4.7 wspierają PHP 7.1. Problemy mogą występować jedynie z niektórymi motywami i wtyczkami. Warto przed aktualizacją zasięgnąć opinii u osoby, która zajmuje się stronami internetowymi.

Joomla

Wsparcie dla PHP 7.0 istnieje od Joomla 3.5. Z PHP 7.1 współpracuje jednakże dopiero Joomla 3.6.4 i to ją zalecamy posiadać na swoim hostingu lub serwerze. Problemy mogą występować przy niektórych wtyczkach i motywach. Warto przed aktualizacją zasięgnąć opinii u osoby, która zajmuje się stronami internetowymi.

Drupal

Wsparcie dla PHP 7.0 pojawiło się razem z Drupal 8. Obsługa PHP 7.1 istnieje w Drupal 8.2 i wyższych. Warto natomiast posiadać zawsze najnowszą wersję. Warto przed aktualizacją zasięgnąć opinii u osoby, która zajmuje się stronami internetowymi.

Michał Olber
Pasjonat nowych technologii, które nie zawsze wykorzystuje w praktyce, ceniąc sobie nade wszystko sprawdzone rozwiązania. Interesuje się sprzętem komputerowym oraz miniaturowymi komputerami. Uwielbia jeździć na rowerze i ćwiczyć kalistenikę.