Blog
Gutenberg

Krytycznie o WordPress 5.0 z Gutenbergiem

Nie tak dawno temu wydano WordPressa 5.0 z całkowicie zmienionym edytorem o nazwie Gutenberg. Dziś mamy już kolejną wersję, która łata dziesiątki błędów w poprzednich wersjach, a specjaliści związani z WordPressem odradzają aktualizacji do 5.x. Zatem, jak to jest z tą nową wersją?

Na początku należy przypomnieć, że wydanie wersji 5.0 było odkładane dziesiątki razy. Powodem była spora ilość błędów, brak kompatybilności i ogólne zamieszanie wokół nowego edytora. Ale stało się i mamy WordPressa 5.0.

Częsty błąd w Gutenbergu.

Twórcy takich wtyczek jak WPML czy Yoast zalecają nie aktualizowanie WordPressa do najnowszej wersji, gdyż wiele rzeczy może nadal nie działać. Powodem jest fakt, że nie było wystarczająco dużo czasu, aby przetestować wszystkie zmiany jakie zajdą w samym WordPressie, a ciągłe poprawki do Gutenberga tylko pogorszały ten stan. Problem ten poruszył Konrad Karpieszuk na stronie dev.wpzlecenia.pl.

Nie minęło wiele czasu i mamy już wersję WordPressa 5.0.2, która poprawia setki błędów jakie zostały znalezione do tej pory. Czy nie można było ich poprawić przed wypuszczeniem Gutenberga na produkcję?

Najgorsze jest w tym wszystkim to, że poprawki bezpieczeństwa jakie zostały wprowadzone w wersji 5.0.1, psują kompatybilność wsteczną! Aktualizacje tego typu nie powinni tak robić.

Najgorsze jest to, że system zgłaszania błędów w WordPressie przestał spełniać swoją rolę. Mają tak dużą liczbę zgłoszonych i otwartych błędów, że sami się w tym gubią.

At the time of publish for this post, there are 473 open tickets in the 5.1 milestone and 55 open tickets in the 5.0.3 milestone (most of which will be punted to 5.1 before the 5.0.3 RC is packaged on January 7th).

make.wordpress.org

Pracujemy z Gutenbergiem już od dłuższego czasu i przez takie ciągłe zmiany i zrywanie z kompatybilnością wsteczną, musieliśmy dziesiątki razy poprawiać wszystkie wpisy na naszym blogu, aby poprawnie się wyświetlały.

WordPress Classic Editor

O złej popularności Gutenberga wskazuje rosnąca popularność wtyczki przywracającej klasyczny edytor jaki był do tej pory w WordPressie.

Klasyczny edytor, który zastępuje Gutenberga.

Ilość pobrani w okolicy wydania wersji 5.0 drastycznie skoczyła w górę. I nie ma co się dziwić. Przy tworzeniu większych wpisów jakim jest niewątpliwie nasze Kompendium, Gutenberg jest nieużywalny. Bardzo często przeglądarka przestaje odpowiadać, bo nie radzi sobie z ilością bloków (ponad 250) w takim artykule.

Statystyki pobrań wtyczki Classic Editor.

Jak wyłączyć Gutenberga?

Najprostszą metodą jest zainstalowanie wcześniej wymienionej wtyczki WordPress Classic Editor. Wtyczka ta jest rozwijana przez twórców WordPressa.

Kolejną wtyczką może być Disable Gutenberg. Posiada ona szereg różnych funkcji, jak możliwość wyłączenia Gutenberga dla specyficznych ról użytkowników lub poszczególnych wpisów.

Patrząc na sposób tworzenia Gutenberga, ilości poprawek jakie pojawiają się tuż po jego wydaniu, mam wrażenie, że twórcy dostarczyli na rynek produkt w wersji beta.

No nic. Czekamy na wydanie stabilne!

Dodaj komentarz!